Elevated Latency for Cloudflare CDN

Incident Report for Statsig

Resolved

Resolved.
Posted Jan 30, 2026 - 23:25 PST

Investigating

We are currently seeing elevated latency for server SDK configuration payloads at our Cloudflare CDN due to congestion at their edge hosts. We are working with them to mitigate the issue.

Update: 01/30/2026 11:49AM PST We have seen some customers seeing latency improve with mitigated congestion. We're still working with Cloudflare to full resolve the issue for everyone.

Update: 01/30/2026 11:25PM PST Latency has been restored to healthy, baseline levels.
Posted Jan 26, 2026 - 17:44 PST
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1).