Statsig experiencing propagation delays

Incident Report for Statsig

Resolved

Resolved.
Posted Mar 30, 2026 - 15:10 PDT

Investigating

From approximately 1:20PM PST to 3:10PM PST, we identified a code path that was creating write pressure on our redis cache which caused propagation to slow down. Resolution was resolved by mitigating the write pressure, and the team is following up on preventative measures to address the root cause. Systems are fully recovered at this point.

Mitigated: 03/30/2026 14:19:00 GMT-0700 (Pacific Daylight Time)
Posted Mar 30, 2026 - 13:20 PDT
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1).