Delayed Configuration Propagation

Incident Report for Statsig

Resolved

Resolved.
Posted Mar 11, 2026 - 13:51 PDT

Investigating

We are currently seeing issues with config propagation for server SDKs. The team is currently investigating and will provide updates soon.

Update: 12:37PM PST

The team has identified what the root cause is and is working on getting a fix deployed now. We are currently aiming for recovery around 1PM.

Update: 1:14PM PST

Most companies should see configuration propagating again, we are continuing to work on full recovery. Delay should at most be a few minutes at this point.

Update: 1:51PM PST

We continue to see config propagation hold at a steady state, the team is working on fast follow ups for prevention to ensure we can confidently mark the incident as resolved.
Posted Mar 11, 2026 - 03:38 PDT
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1).