Client SDK Success Rate in Southeast Asia

Incident Report for Statsig

Resolved

Resolved.
Posted Mar 17, 2026 - 19:53 PDT

Investigating

We are seeing degraded success rate in our southeast asia region for client SDK initialization starting at around 6:50PM. The team has identified the root cause and is working on recovering the region now.

Update: 7:51PM PST -- The team expects full recovery within a few minutes.

Update: 7:57PM PST -- Systems are fully recovered as of 7:53 PM PST.
Posted Mar 17, 2026 - 18:50 PDT
This incident affected: Config Delivery API (Asia Southeast 1).