11/18/2025 06:50:00 GMT-0800 (Pacific Standard Time)

Incident Report for Statsig

Resolved

Resolved.
Posted Nov 18, 2025 - 06:51 PST

Investigating

We are seeing recovery on affected requests via cloudflare as of 6.42am PT. We will continue to monitor the health of our systems as we recover.
Mitigated: 11/18/2025 05:34:00 GMT-0800 (Pacific Standard Time)
Posted Nov 18, 2025 - 06:50 PST
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1).