Data propagation delays

Incident Report for Statsig

Resolved

Resolved.
Posted Oct 31, 2025 - 14:53 PDT

Investigating

There were propagation delays across multiple regions caused by a bad config pushed earlier today, impacting the SDK and CDN. Additionally, there were also slower than real time ingestion speeds which affects data realtimeness in console surfaces such as diagnostics and dashboards. The team has identified the rootcause and system health has been restored.
Posted Oct 31, 2025 - 14:52 PDT
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1) and Experiment Results (Cloud), Event Forwarding Pipeline (Warehouse Native).