All US-West Requests Failing

Incident Report for Statsig

Resolved

Resolved.
Posted Oct 22, 2025 - 17:35 PDT

Investigating

Starting at 5:10PM PST, a networking change was made which caused an outage of all endpoints going to our US-West region to route to the incorrect backend causing exceptions, such as filter abort/RBAC denied. The team has addressed the networking change, and the US-West region should be fully recovered as of 5:35PM.

Only configuration APIs for SDK initialization, background syncing, and console API was impacted. All other APIs are confirmed healthy during this incident.

Mitigated: 10/22/2025 5:40 PM PST
Posted Oct 22, 2025 - 17:10 PDT
This incident affected: Config Delivery API (US West 1) and Console API.