Slack Integration Oversending

Incident Report for Statsig

Resolved

Resolved.
Posted Dec 11, 2025 - 13:30 PST

Investigating

Customers with multiple Slack channels configured are receiving messages in all channels, instead of only those filtered to the individual channel. We are investigating the issue.
Mitigated: 12/11/2025 1:30:00 GMT-0800 (Pacific Standard Time)
Posted Dec 11, 2025 - 11:52 PST