Degraded SDK initialization global success rate

Incident Report for Statsig

Resolved

Resolved.
Posted Oct 30, 2025 - 12:20 PDT

Investigating

Starting at 11:56AM PST, a networking configuration change caused a partial outage for SDK initialization APIs (/v1/initialize, /v1/download_config_specs, /v2/download_config_specs) in all clusters.

The team is in the process of fast reverting this change, which will restore availability shortly.
Mitigated: 10/30/2025 12:20:00 GMT-0700 (Pacific Daylight Time)
Posted Oct 30, 2025 - 11:56 PDT
This incident affected: Config Delivery API (US West 1, US East 1, US East 5, Europe West 1, Asia Southeast 1).